Problems with 123Solar/config

Talks about solar stuff
Post Reply
noelkc
Posts: 1
Joined: Tue Jul 26, 2016 2:45 am

Problems with 123Solar/config

Post by noelkc » Tue Jul 26, 2016 3:16 am

I am new to 123Solar, which I have installed on a Raspberry Pi. When I make any configuration changes via the web interface, I get a confirmation that changes have been saved. When I try to access 123Solar/config again, I log in, but get only a 123Solar Administration screen that is otherwise empty. I have restarted 123Solar, and reboot the host in between. I can see that the changes have been written to config_main.php, but when I browse to 123Solar, I only see the default settings. My config_main.php with minimal changes below

<?php
if(!defined('checkaccess')){die('Direct access not permitted');}
// ### GENERAL
$PORT='/dev/ttyUSB0';
$COMOPTION='-Y3';
$DEBUG=0;
$SYNC=0;
$NUMINV=1;
$AUTOMODE=1;
$DISTRO='arch_ARM';

// ### LOCALIZATION
$DTZ='Australia/Brisbane';
$LATITUDE=50.61;
$LONGITUDE=4.635;
$DATEFORMAT='d/m/Y';
$DPOINT='.';
$THSEP=',';

// ### WEB PAGE
$TITLE='123Solar logger';
$SUBTITLE='Noel's Solar Array';

// ### CLEANUP
$KEEPDDAYS=0;
$AMOUNTLOG=1500;
?>

jeanmarc
Posts: 1867
Joined: Thu Aug 29, 2013 7:16 am

Re: Problems with 123Solar/config

Post by jeanmarc » Tue Jul 26, 2016 6:50 am

Hi,
Did you use the latest version ? Quote aren't allowed that text variable => $SUBTITLE='Noel's Solar Array';
You have screw the config file. Please, rather use the interface and respect the permissions => extract 123s with tar -xzvf

Post Reply

Who is online

Users browsing this forum: No registered users and 11 guests