Page 1 of 1

FATAL: kernel too old after running pacman -Syu

Posted: Fri Aug 19, 2016 1:07 pm
by kitenski
I realise this is not an issue with 123solar but I seem to have broken my Pogoplug system so badly that 123solar won't even run now and am desperate for some help.

I just tried to update my system running the pacman -Syu command.

checking back through the screen I see numerous similiar errors:
( 3/66) upgrading glibc [######################] 100%
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
FATAL: kernel too old
error: command failed to execute correctly
%
(14/66) upgrading dash [######################] 100%
FATAL: kernel too old
error: command failed to execute correctly

I am now back at a command prompt as root, but many commands are not working,
[root@alarm ~]# ls

FATAL: kernel too old
Please can someone suggest how I can get this resolved? I've not rebooted or logged out for fear of making it worse.

This is all installed onto a USB stick so I can unplug that and plug it into my desktop system which is running Ubuntu if I can then copy some files over to fix it?

As you can guess I am fairly inexperienced with Linux.

regards,
Greg

Re: FATAL: kernel too old after running pacman -Syu

Posted: Fri Aug 19, 2016 1:14 pm
by jeanmarc
doh :o Do backup the data and config directories and restart from scratch..
:idea: Lessons learned: Always keep up to date and do automatic backups

Re: FATAL: kernel too old after running pacman -Syu

Posted: Fri Aug 19, 2016 1:38 pm
by kitenski
doh indeed!!

for future reference does the kernel update itself by doing pacman -Syu regularly??

Re: FATAL: kernel too old after running pacman -Syu

Posted: Fri Aug 19, 2016 1:48 pm
by jeanmarc
No, you need to do pacman -Syu once in awhile..