fastcgi/php error

Talks about solar stuff
Post Reply
jerrymex
Posts: 13
Joined: Fri May 03, 2019 11:56 pm

fastcgi/php error

Post by jerrymex » Sat Aug 31, 2019 1:55 pm

On Thursday, 29 Aug 2019 at approx. 9:30 AM, we lost electrical power, and was not restored until about 9:30 PM.
On Friday morning, I checked to see if 123solar was working, it was not.
The error in /var/log/nginx/error.log shows as:

2019/08/31 06:58:41 [error] 510#510: *66626 FastCGI sent in stderr: "PHP message: PHP Notice: Undefined index: invtstat1 in /srv/http/123solar/programs/programdashboard.php on line 15PHP message: PHP Notice: Undefined index: peakotd1 in /srv/http/123solar/programs/programdashboard.php on line 16PHP message: PHP Notice: Undefined index: peakoat1 in /srv/http/123solar/programs/programdashboard.php on line 17" while reading response header from upstream, client: 192.168.1.29, server: localhost, request: "GET /123solar/programs/programdashboard.php?invtnum=1 HTTP/1.1", upstream: "fastcgi://unix:/run/php-fpm/php-fpm.sock:", host: "192.168.1.10", referrer: "http://192.168.1.10/123solar/dashboard.php?invtnum=1"

Pointers on how to correct would be appreciated.
Thanks

jeanmarc
Posts: 2022
Joined: Thu Aug 29, 2013 7:16 am

Re: fastcgi/php error

Post by jeanmarc » Sat Aug 31, 2019 3:08 pm

Hi,
Maybe /dev/shm/123s_MEMORY.json is locked or corrupted. Try to a reboot with fsck.
Then enable debug to get more details, if it's not ok.

jerrymex
Posts: 13
Joined: Fri May 03, 2019 11:56 pm

Re: fastcgi/php error

Post by jerrymex » Sun Sep 01, 2019 1:42 pm

Well that fixed the issue and appears to be logging.
Thanks

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests