123Solar Conection error in events

aurora protocol http://www.curtronics.com/Solar/
Peter_11
Posts: 15
Joined: Fri Sep 05, 2014 1:15 pm

123Solar Conection error in events

Post by Peter_11 » Fri Sep 05, 2014 1:22 pm

Hello,
I am newbie here and I have problem with 123solar. On the admin page everything seem to be OK, also TEST connection work every time I try, but on INFO page I get always Communication problem and in CSV directory is nothing generated.

I have also problem with library calendar.so, because PHP could not find it and me as well. How can I get it it?

Peter

jeanmarc
Posts: 1764
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar Conection error in events

Post by jeanmarc » Fri Sep 05, 2014 1:29 pm

Hi,

About "Communication Error"...
About CSV, make sure you properly extract 123solar (tar -xzvf..)
About calendar, uncomment remove the ; of extension=calendar.so in /etc/php/php.ini

Peter_11
Posts: 15
Joined: Fri Sep 05, 2014 1:15 pm

Re: 123Solar Conection error in events

Post by Peter_11 » Fri Sep 05, 2014 1:35 pm

I do not understand why communication is OK when I try it via Admin page.

jeanmarc
Posts: 1764
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar Conection error in events

Post by jeanmarc » Fri Sep 05, 2014 1:41 pm

123s pool like a freak your inverter. If you don't have a reliable connection, you'll get incomplete data and com errors.

Peter_11
Posts: 15
Joined: Fri Sep 05, 2014 1:15 pm

Re: 123Solar Conection error in events

Post by Peter_11 » Fri Sep 05, 2014 1:49 pm

I do not know why 123solar asking inverter so often, I have checked on Admin page and Event pooling interval is 5 minutes now.

jeanmarc
Posts: 1764
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar Conection error in events

Post by jeanmarc » Fri Sep 05, 2014 2:02 pm

because of live things.. The "event" pooling you said is the "Alarms and Warnings" pooling. :roll:

Peter_11
Posts: 15
Joined: Fri Sep 05, 2014 1:15 pm

Re: 123Solar Conection error in events

Post by Peter_11 » Fri Sep 05, 2014 2:08 pm

Is anything what I can do with this?

If I try get the values from command line:

aurora -b -a1 -c -T -w10 -Y100 -d0 -e /dev/virtS0

I get successful results even if I do it every second

jeanmarc
Posts: 1764
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar Conection error in events

Post by jeanmarc » Fri Sep 05, 2014 2:52 pm

I suppose that communication problem were "Communication error" in events log. So, put that options in "Communication options".

Peter_11
Posts: 15
Joined: Fri Sep 05, 2014 1:15 pm

Re: 123Solar Conection error in events

Post by Peter_11 » Mon Sep 08, 2014 7:06 am

I tried everything. In de.err I have this error.

estoring Serial Port settings /dev/virtS0... Success!
Flushing serial device buffer... Success!
Closing Serial Port /dev/virtS0... Success!

devLCKfile: </var/lock/LCK..virtS0>
devLCKfileNew: </var/lock/LCK..virtS0.27269>
Clearing Serial Port Lock (27269)... done.

20140908-08:06:13: aurora: ERROR: Received bad return code (-1 59 31)

Complete 20140908-08:06:13

jeanmarc
Posts: 1764
Joined: Thu Aug 29, 2013 7:16 am

Re: 123Solar Conection error in events

Post by jeanmarc » Mon Sep 08, 2014 7:14 am

'told ya. The communication didn't end up properly.. As the help say : "Please read the communication app manual. For aurora, try it alone and adjust the parameters (-Y, -R, -l, -P). Change then the communication options in the admin. interface."
If you are too annoyed by those messages, you may skip them in the admin interface (set Log com. errors to no). But remind that you haven't got a reliable connection.. :ugeek:

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest