Problem with aurora post rebuild

aurora protocol http://www.curtronics.com/Solar/
Post Reply
kitenski
Posts: 31
Joined: Mon May 12, 2014 10:01 pm

Problem with aurora post rebuild

Post by kitenski » Wed Aug 31, 2016 10:01 am

Morning,

I rebuilt my system after some issues with Linux, however it appears to now only communicate with the invertor at the start of the day, then drops the connection?

reading the debugger page it says the following:

"You also need to grant the access to your com. apps. Locate with 'whereis mycomapp' and chmod a+x /pathto/mycomapp.py."

However I don't seem to have this at all, is that perhaps my issue?

[alarm@Plugbox errors]$ whereis mycomapp
mycomapp:

ankn99
Posts: 14
Joined: Thu Aug 25, 2016 6:59 am

Re: Problem with aurora post rebuild

Post by ankn99 » Wed Aug 31, 2016 11:45 am

Hi,

What HTTP(WEB)-Server are you using ?
What System are you using ?

Can you call the example-page which was installed together with your Web-Server from a Browser ?
Do you have the php module installed (in case of Apache ) are you running php programs with FPM ?

How does your Linux-Machine communicates with your Inverters ? (Bluetooth, LAN, RS485 etc.)

jeanmarc
Posts: 1822
Joined: Thu Aug 29, 2013 7:16 am

Re: Problem with aurora post rebuild

Post by jeanmarc » Wed Aug 31, 2016 11:59 am

Code: Select all

[root@i3 ~]# whereis aurora
aurora: /usr/local/bin/aurora
[root@i3 ~]# chmod a+x /usr/local/bin/aurora
;)

That say, if you inverter is sometime able to communicate, that's not the problem. Try aurora alone before and and make sure it is reliable ! (as the README say)

kitenski
Posts: 31
Joined: Mon May 12, 2014 10:01 pm

Re: Problem with aurora post rebuild

Post by kitenski » Wed Aug 31, 2016 5:49 pm

mucking around with the Y parameter (and increasing it from 3 to 11) appears to have fixed the aurora issue.

Still interested as to whether I need to worry about mycomapp.py missing or not?

@ankn99 the webserver works fine, it's serving up 123solar and other pages just fine.

jeanmarc
Posts: 1822
Joined: Thu Aug 29, 2013 7:16 am

Re: Problem with aurora post rebuild

Post by jeanmarc » Wed Aug 31, 2016 6:13 pm

mycomapp.py is an example :)

kitenski
Posts: 31
Joined: Mon May 12, 2014 10:01 pm

Re: Problem with aurora post rebuild

Post by kitenski » Wed Aug 31, 2016 6:22 pm

jeanmarc wrote:mycomapp.py is an example :)
DOH!!! so aurora is "my com app" then ;)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest